The Farm Runner

NYCEGUY01

Well-Known Member
Location
Willard, UT
SO.....
Im in constant limbo waiting on parts for my other truck so I figured Id work on this side project with stuff I mostly already had here.
This will be bridging a couple other projects here Ive been watching.
Ive been digging the farm truck and Dirt Muscle car builds so.....


I bought this old Dept of Agriculture Stepside a while back and finally got it all running last week.
I initially was just gonna flip it but.. who doesnt need another truck..lol
Its painfully slow currently with the 250 straight 6, SM465, and 2.73 rear gears...lol The motor will barely pull 4th gear on flat ground...Ugh...

For now, I did a comet wash and linseed oil shine.. Really looking pretty good overall. The dark green color and rust go well together...


ac9.jpg

ac5.jpg

I pulled it in the garage this morning and tore all the front suspension off, Its all bad, had a popped brake line, a stuck caliper...and was all junk.
Grabbed all new brake parts and started re-assembly today.

Ive had this prerunner suspension stuff in the shed for years so may as well use it at some point, Today is that some point...
Old school Fabtech +2.5" per side long travel.
I think its gonna need an alignment...lol

frnr.jpg

rrnr.jpg

Tomorrow Ill pull it back in and get the engine cage/ Shock hoops installed along with the front dual Fox 2.0's

I ordered some u-bolts for the rear and next week Ill get a rear axle underneath it, Gonna steal the one from the Brown K10 as its getting a 9".
I found a 2wd 12bolt I can steal the axle shafts out of to convert it to 5 lug and the 4.56's and truetrac will be awesome in this truck. Then Ill build some kind of rear hoops and stick some 2.5" shocks up into the bed area . Because Pre-Runner...lol

Ive got 3 Near new 35" General x3's here so I ordered a 4th and have the set of old Raceline wheels I took off the Blazer way back when I added beadlocks.
Ill see how the 35's they fit and then cut off anything in the way at that point.


Near Future plans are a smallblock and th350, A set of PRP's I have from another build and then do burnouts and donuts while not caring if I scratch it.

More to come.....
 
Last edited:

NYCEGUY01

Well-Known Member
Location
Willard, UT
Been sick for over a week now so havent gotten any more real work done.
I have figured out everything Im missing I think and gotten parts ordered though.

I also got the cage out of the parts truck so I can work on welding it in this one and get the PRP's all mounted in there as well.

Its up on stands in the garage now so I can swap out the front coils for some shorter ones and then install the 6 lug rotors and new brakes etc...

I did get to the tire shop today though and get the tires mounted on the new wheels...
This time I went with skinny 15x8's but... More Slot mags...
Just couldn't bring myself to use the old wheels I wasnt in love with.
All the cool old Dezert rucks had these.....

Not much but at least a little progress.... More to come...

slots.jpg
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Front end is finally all in. I cut a coil off to bring it down a little and then straightened it up a little. Will still need an alignment once its mobile again.
Also mounted the new Spindles, Rotors, Calipers, and stainless hoses today.
Mounted the new power steering box to replace the manual box but I wont have a pump on it till I do the motor swap.
Also trimmed the front fenders a little to clear the tires, the fenders were pretty rusty so no loss there.
It did make a huge mess from all the rust and dirt falling out of the fenders when the sawzall started vibrating things.

Tomorrow should be good to toss in the rear axle and get it on all fours and install the hydroboost and new master on the firewall and if everything goes OK Ill get the brakes all bled etc... Will install the Auto pedals with the hydroboost as its most the same bolts holding both in.

Making a little progress at least...
Lastly, Finally picked out a cam for the 383 and got it ordered. It may be a dog but there is enough duration (246 @ .050) for a choppy ass idle.
Its geared low enough and Im running a 3200 stall so it should be about right...

More to come,,,

44.jpg33.jpg22.jpg11.jpg
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Went out before it got hot this morning and got the new rear axle swapped in.
Currie 35 spline 10" ring gear truetrac with 4.10's.

( I was surprised to see the ring gear was machined down to like 9.5 but they still call it a 10" lol )


Way overkill for this truck but its badass and I already had it. Lol

All the brake likes and cables actually swapped right in with no issues.

Was able to get the ride height set and get the matching rear wheels and tires on it.

Its gonna take forever but I'm knocking off small chunks one at a time.

After being sick for a couple weeks (turned out to be pnemonia) even little projects like this rear axle swap are kicking my ass still.

More to come. 20220618_105822.jpg
 

Attachments

  • 20220618_105829.jpg
    20220618_105829.jpg
    511.2 KB · Views: 23

NYCEGUY01

Well-Known Member
Location
Willard, UT
Still making some progress.. Slowly...

Got the motor and trans installed and will get the driveshaft ordered tomorrow.
Installed the radiator and shroud so I could measure for a fan spacer and fan. Straight old school mechanical, Hard to beat to keep cool.

With the motor in and the hood back on it can now come inside and I can start knocking off little projects as I have time...

Still need to install the fuel cell and plumb it, plumb the trans cooler and hydroboost lines then I can get it fired up.
Then just 450 other small tasks and I can go beat on it...lol

motor.jpg
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Not a huge update but after 4 or 5 days of work I needed a shot in the arm to get a little motivation to get it done...lol

Got it fired up and broke in the cam for about 30 min yesterday.

Of course the front crank seal is leaking oil and the temp sensor fitting is leaking water but I hooked up the gauge and got the idle mixture and timing set. Set of for 38 degrees at 3250 rpm. Put me at 18 at idle. May need some tweaking to see what it likes and if the power valve will need dropped. It for sure is gonna need a bigger squirter though.

I got another $200 worth of parts on the way...lol

Its been quite a while since I had one that wouldnt idle below 950rpm... Will have to be at about 1k to keep it running in gear though...

The compression isnt very high but the cam still has a pretty good sound at idle this morning....


Still have to get shocks mounted, mount the fuel cell (Its plumbed but just sitting in the bed) and then put in the roll bar and build seat mounts but it seemed like it was already too hot today for cutting, welding, and grinding..lol


 
Last edited:

Greg

Make RME Rockcrawling Again!
Admin
Not a huge update but after 4 or 5 days of work I needed a shot in the arm to get a little motivation to get it done...lol

Got it fired up and broke in the cam for about 30 min yesterday.

Of course the front crank seal is leaking oil and the temp sensor fitting is leaking water but I hooked up the gauge and got the idle mixture and timing set. Set of for 38 degrees at 3250 rpm. Put me at 18 at idle. May need some tweaking to see what it likes and if the power valve will need dropped. It for sure is gonna need a bigger squirter though.

I got another $200 worth of parts on the way...lol

Its been quite a while since I had one that wouldnt idle below 950rpm... Will have to be at about 1k to keep it running in gear though...

The compression isnt very high but the cam still has a pretty good sound at idle this morning....


Still have to get shocks mounted, mount the fuel cell (Its plumbed but just sitting in the bed) and then put in the roll bar and build seat mounts but it seemed like it was already too hot today for cutting, welding, and grinding..lol


Sounds awesome!
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Seats and shifter are now mounted. Still a ton of things on the list..lol

The idle speed and mixture was giving me fits the other day so I hooked the vacuum gauge back up and played some more.
The mixture screws werent hardly making any change again which seemed pretty odd.
It was also running WAY rich at idle, like my eyes were burning...

Its been a long time since I tuned anything with this much duration on the cam and then after sweating over the motor for an hour.....

I only have about 5" of vacuum and the carb came with a 6.5 powervalve in it.. Ugh...
The valve is opening and dumping like 8-10 jet sizes of fuel in it... I tossed in a blockoff i had to verify and its good to go.
Off to Summit to order a 2.5 and 1.5 powervalve...

Getting closer....

seats.jpgshifter.jpg
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Nothing worthy of new pics today but I finally stopped the oil leak a the front crank seal. It was a gusher.
The seal wasnt awesome looking once I had it out and seemed pretty brittle for a new seal, I literally bent it and broke out a chunk of the rubber lip ? Damn chinese dried up seal. ugh...
The balancer also had a good groove in it, it was one I had here and seemed on but I had a new one on the shelf so might as well just install it...

Prettty basic job except my chinesium Harmonic Balancer puller Ive had for 10 years or more finally gave up and pulled all the threads out of it....lol

After that was all done I found that the secondary float bowl looked empty through the sight glass and I found after taking it apart the needle and seat was stuck and all but closed. Threw in a new one of those and adjusted her all up..

Finished getting the 10 degree stop bushing in the distributor and got the timing and idle mixture all setup.
This cam needed a ton of initial advance so I had to limit the total.
Seems perfect now at 26 degrees initial and 36 @ 3600 rpm. Then I hooked the vac advance back up and set the MSD to give me 10 degrees of start retard. It now idles at around 1000 rpm steady and pulls 8" of vacuum. Then I had to put the bigger powervalve back in..lol

After all that I pulled it out back and cleaned up the front of the motor , frame, and crossmember to get rid of all the oil that had leaked everywhere so I could be sure it stayed dry.

Lastly, I took it for a little test drive down the dirt road behind the house, Didnt hammer it too hard as there was loose stuff in the bed but...

I cant wait to get the gears in it and take it for some full throttle blasts, I ran it up to 5000 ish rpm or so in first and second gear and cruised it in 3rd and even without matting it she seemed to pull damn good...

She is gonna be rowdy
 

NYCEGUY01

Well-Known Member
Location
Willard, UT
Haven't posted much on this one but its done enough to take to the dragstrip next week.

Suspension is all done and aligned.
Motor is all tuned in and running now.
Finished the nitrous wiring and Park safety switch the other night so that part is finally done.

Wired a master on / off toggle and then just tapped into the stock full throttle switch on the gas pedal for the transmission to activate the nitrous.

Gonna spray it right off the line. I Threw in 75hp jets to start and we will go from there.
I can make it a bunch faster but I'll have to watch the AFR and make sure we dont burn it down if we step up the jet sizes.

Lastly, I installed the PRP lap belts. I have the full harnesses but those will have to wait for the cage to be done. All I have gotten done so far there is the main hoop its solid but for decoration currently. Lol


Had to swap out an oil pan this morning as the brand new one on the motor was leaking everywhere, right through the welds even.

New Milidon gold iridated installed this morning and not leaking. For the moment.

Still needs 50 more things like the grille and all the turn signals installed and wired but it has a tail light and headlights so it's good enough to pass tech.

Closed the hood and I'm calling it good enough for the moment.


Gotta a bunch of work.to do on the towrig so this one Is good enough for now.
 

Attachments

  • 20220924_132714.jpg
    20220924_132714.jpg
    333.9 KB · Views: 20
  • 20220924_132703.jpg
    20220924_132703.jpg
    316.6 KB · Views: 20
  • 20220924_132628.jpg
    20220924_132628.jpg
    275.1 KB · Views: 20
Last edited:

NYCEGUY01

Well-Known Member
Location
Willard, UT
We had rain off and on so I didn’t get to rejet and spray it to the goal of 13.xx and over 100mph but she got pretty close..lol
Still had a blast.
Now I have to get the cage finished and I’m not sure what I’m gonna do for motor quite yet but it needs about 250 more hp…
Decided it’s gonna run substantially faster next year….

The only real issues we had was the fan belt coming off. Burnouts in 2nd gear on the 6500 rpm limiter seemed to eject it pretty quick…lol
 

Attachments

  • 944154D6-81B1-4ED2-9AF4-51F033F71680.jpeg
    944154D6-81B1-4ED2-9AF4-51F033F71680.jpeg
    305.1 KB · Views: 38
  • 3F31FBC4-4CC7-437A-88B5-5B1258C812DD.jpeg
    3F31FBC4-4CC7-437A-88B5-5B1258C812DD.jpeg
    168.3 KB · Views: 37
  • 4ED6CDCC-9C88-4940-938E-ACA2A1A76D33.jpeg
    4ED6CDCC-9C88-4940-938E-ACA2A1A76D33.jpeg
    202.1 KB · Views: 37
Top